Corporate Website SSL Certificate

Incident Report for Causaly

Resolved

Issue is now resolved.
Posted Mar 18, 2022 - 11:52 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 18, 2022 - 11:52 UTC

Investigating

We are currently investigating an issue with our SSL certificate that is only affecting our corporate website, Causaly Cloud is fully operational.
Posted Mar 18, 2022 - 11:36 UTC