Disruption To Service
Resolved·Full outage

The recent outage has been resolved and Causaly services are fully restored. We appreciate your patience and apologize for any inconvenience. If you continue to experience any issues, please contact us at support@causaly.com.

Fri, Jul 18, 2025, 06:15 PM
(1 month ago)
·
Affected components
Updates

Resolved

The recent outage has been resolved and Causaly services are fully restored. We appreciate your patience and apologize for any inconvenience. If you continue to experience any issues, please contact us at support@causaly.com.

Fri, Jul 18, 2025, 06:15 PM

Monitoring

Our cloud provider has made progress resolving their infrastructure issue. Our systems are continuing to recover as a result. We're monitoring the restoration process closely and working to ensure all services return to normal operation. We apologize for the inconvenience and appreciate your patience.

Fri, Jul 18, 2025, 05:05 PM(1 hour earlier)

Identified

Causaly is currently experiencing a partial outage due to an issue with our cloud provider. We are closely monitoring the situation and will restore service as soon as the issue is resolved. We apologize for any inconvenience.

Fri, Jul 18, 2025, 04:03 PM(1 hour earlier)

Investigating

We are continuing to investigate this issue.

Fri, Jul 18, 2025, 03:51 PM(12 minutes earlier)

Investigating

We are continuing to investigate this issue.

Fri, Jul 18, 2025, 03:50 PM

Investigating

Causaly is currently experiencing a complete outage. Our team is investigating the cause and working hard to restore normal performance levels. We apologize for any inconvenience.

Fri, Jul 18, 2025, 03:07 PM(43 minutes earlier)
Powered by